USB Midi keyboard, MuseScore, and Linux

Just because this stuff isn’t obvious:

I have my M-Audio KeyStudio 25 keyboard working as an input device for MuseScore under Ubuntu 16.04. Steps I used:

  1. Plugged in the keyboard.
  2. Started MuseScore. I had version 2.0.2 installed because that’s what Ubuntu Software Center finds and installs.
  3. Edit > Preferences > I/O. Checked PortAudio. Nothing obvious happened.
  4. Clicked OK.
  5. Quit and restarted MuseScore.
  6. Edit > Preferences > I/O. Now API is ALSA and Device is default. Good.
  7. Went into note entry mode, mashed some keys on the MIDI keyboard, they got entered. Huzzah.

But I had a later version of MuseScore on my Mac, so I uninstalled it in Ubuntu Software Center, then went to https://launchpad.net/~mscore-ubuntu/+archive/ubuntu/mscore-stable and followed the instructions:

  1. sudo add-apt-repository ppa:mscore-ubuntu/mscore-stable
  2. sudo apt-get update
  3. sudo apt-get install musescore

But then I had to do:

  1. Edit > Preferences > I/O. MIDI Input is ALSA, Midi Through Port-0. Changed it to ALSA, USB O2 MIDI 1.
  2. Clicked OK.
  3. Quit and restarted MuseScore.
  4. Went into note entry mode, mashed some keys on the MIDI keyboard, they got entered. Huzzah again.

 

Advertisements

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out /  Change )

Google+ photo

You are commenting using your Google+ account. Log Out /  Change )

Twitter picture

You are commenting using your Twitter account. Log Out /  Change )

Facebook photo

You are commenting using your Facebook account. Log Out /  Change )

Connecting to %s